Default LFD more felxible

Using the Internal Comms template

The Colleague directory, detail view has phone & email & linked in as default. However these are sensitive information and for the application we are creating so they cannot be shown.

While I appreciate it is designed for a different purpose flexibility in a standard out of the box page on sensitive contact information would be nice.

The solution is to comment out the field in the HTML, and or put the sensitive information into a different field.

Hi Mark,

Thanks for your feedback.

This can be amended in the data view settings, you can just remove the fields and select “select a data field” as the option instead. This was no icons will appear for these options.

Hi Mel

I have attached a screen shot of the Colleague, Detail

There is no obvious way of removing the Email, Phone Icon, LinkedIn and the information field on this page as on other pages. – unless I have missed something?

When I do attempt to make a change say add a field – I get an error coming up which says - “Please select a value on the fields marked as required”

Testing I get the same error when I do no more than change the order or delete a field I get the same message - “Please select a value on the fields marked as required”

So basically it does not like/accept any change made to it…… Again unless you can show me what I have missed?



Hi Mark,

This error is not for these fields but referring to some settings for entry management. At this current moment that is a bug as it is not saving an entry from the settings. This has been raised and once fixed won’t cause any problems.

If you remove the email, phone and linked in fields, select “back to settings” at the top, and then revisit the entry management settings, you’ll see the author email field needs filling in. Then you can save and close.

Apologies that this is slightly confusing, this bug was picked up today and should be fixed shortly so in the future you can simply remove those fields, then select save & close, if all other settings are filled in correctly.


But your answer does not answer my question, how to remove the email, phone and linked in fields from showing.

Fortunately I have now found how to stop the icon from appearing, however the answer was not obvious and the text is equally obfuscated.

Phone, Email, LinkedIn Icon

These icons are buttons in the detail view. Add the corresponding fields or choose “– Select a data field” if you do not want an option to display.

Hi Mark,
The instructions are as above. For those fields in the data view settings you should chose “select a data field”, whilst the bug for settings is in place the additional step is to select “back to settings”, ensuring the entry management fields are filled in.